button link for contact page

Pre-Installation Requirements

Pre-Installation Requirements

Fitrix Pre-Installation Requirements

This is the information your IT department will need to spec and configure clients and servers to meet the prerequisits of Fitrix. Please select the Version of Fitrix you will be installing:

Fitrix Version 6.0

Fitrix Version 5.4x

Fitrix Version 5.3x

Fitrix Version 5.2x